Jump to content
Sign in to follow this  
Wryter

My DVD autoplay is dead!

Recommended Posts

OK - I'm not blaming you good folks - BUT. Shortly after I used ImgBurn for the first time, the autoplay on my DVD player quit cold.

I've tried TweakUI (shows all is normal) I've downloaded MS autoplay fix - which shows autoplay V2 is not working, but says it can't fix it. I've gone into regedit, which tells me all settings are good. I've used Registry Mechanic and two other programs, which tell me ev-ting's OK.

I've R-clicked on the menu for the DVD drive and my USB thumb drives, one by one, and set all to autoplay. Nope. It's not to be.

Any suggestions would be WELCOME! (sigh)

 

ImgBurn, BTW, works flawlessly - and I've happily used it five times now.

 

Respectfully. . .LarryR

Share this post


Link to post
Share on other sites

ImgBurn adds its autoplay entries but doesn't touch the other options so the problem may be elsewhere. Anyway, as Cynthia pointed out, check the Registry tab, and it might also be worth looking in the Device tab. Have you tried re-installing your DVD player software? That should fix its autoplay ability.

Share this post


Link to post
Share on other sites

look at hkey_classes_root\DVD in regedit.

 

Export that key to a file and open it in notepad. Then copy + paste what it says into the forum.

 

Assuming all the relevant keys are still in place (which they should be), right click on the dvd drive in question within explorer/my computer and select properties. Hopefully in there you'll find an AutoPlay tab and will work the rest out yourself.

Share this post


Link to post
Share on other sites

Man, you should be happy - autoplay is a real PITA (at least IMHO).

 

Anyway, check out this key in regedit:

 

HKeyLocalMachine/System/CurrentControlSet/Services/CDRom

 

Change autoplay from 0 to 1 and reboot.

 

Regards

Share this post


Link to post
Share on other sites

Doh, I just noticed you've already done the right click -> properties thing on your drives.

 

The autoplay stuff can be enabled / disabled via the checkboxes on the 'Device' tab within ImgBurn's settings (as mmalves mentioned earlier).

 

(i.e. that's the HKEY_LOCAL_MACHINE/System/CurrentControlSet/Services/CdRom that blutach just mentioned)

Share this post


Link to post
Share on other sites

Whew! Sorry - my e-mail notification got accidentally turned off. OK - I've checked both the Device and Registry menu sections to be sure all is checked that should be. It's OK.

Went into Regedit and the . . . .Services/CDrom autoplay was set to 1, not 0.

Also checked HKey_classes_root\DVD. It read:

Name - (Default) Type - REG_SZ Data - (value not set) Is that a problem? I haven't the foggiest. . .

 

As to reinstalling my DVD software - it came "bundled" with the Dell computer, and there's not many CDs in the package. A hint as to how I reinstall this? SIGH. . .

 

Sorry to be such a bother. Again - it is NOT in anyway the fault of ImgBurn, but you folk seem so knowledgeable and patient that I thought I'd "bare my soul" and hope for help.

 

Respectfully. . .LarryR

Share this post


Link to post
Share on other sites

When you put a disc in the drive that won't autoplay, what exactly is happening?

 

If you have the 'My Computer' window open when you insert one, does the drive name/icon change?

 

What options do you see on the right click menu once the disc has been in for 30 seconds?

Share this post


Link to post
Share on other sites

First - thank you for your reply. Usually I get "the brush-off" at most forums. I appreciate this one!

 

Now: when I insert a DVD it spins for a few seconds, then opens up C:\Documents & Settings\ our log-on name.

Then, the disc just spins for awhile, then stops. The on-screen display does not change.

 

With My Computer open - when I put in the DVD it does show the content (movie title, opera, etc.) but the drive letter (D:) remains the same.

 

When I R-click on the disc drive in My Computer the menu I'm presented with is as follows - top down.

 

Read using ImgBurn - Browse with FastStone - Search - Open - Explore - Autoplay (which won't) Scan with AVG antivirus - eject - copy - create shortcut - properties.

 

That's it. Oh, yes - the D drive DOES auto play music CDs, but not DVDs. Also, the USB thumb drives on which I store backups won't autoplay, either. Sigh.

 

Respectfully. . . LarryR

Share this post


Link to post
Share on other sites

If you go to...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

and...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

what's the NoDriveTypeAutoRun value on each one of them? The default value is 0x00000091 (145).

Share this post


Link to post
Share on other sites

After checking the registry - yes, 91 (145) is the set figure there.

 

Thanks for your reply!

 

Respectfully. . .LarryR

 

EDIT: but let me add here that there are TWO autorun settings - the second is for NoDriveAutoRun - REG_BINARY 01 00 00 00.

 

And at the top, under Explorer, is the drive itself - Default - REG_SZ (value not set)

 

Also - NOTE - in the HKEY Local Machine thread in the registry, there is no "policies" in the string - it goes from CurrentVersion right to Explorer. Same driver setting as with Current_User - Default REG_SZ (value not set) - BUT -

There is NO "noDriveAutoRun" or "NoDriveTypeAutoRun" listed there at all! Missing, though I'm not sure it should be there? Please help me on this.

Edited by Wryter

Share this post


Link to post
Share on other sites
If you go to...

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

and...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

what's the NoDriveTypeAutoRun value on each one of them? The default value is 0x00000091 (145).

 

WHOA! You may be on to something here! Should there be a NoDriveTypeAutoRun key under Explorer in the local_machine as well? And if so, can I just modify Explorer so that the thread is added to it? Hmm. . .this may be my problem? THANKS!

Share this post


Link to post
Share on other sites
You have checked the tab 'Registry' in the settings of ImgBurn?

Cynthia can you please tell me how to get Shrink to burn Create ISO Image file and burn using Image Burn, the only option I have use dvd Decrypter. I believe I missed a setting somewhere or don't have the correct version installed. Shrink 3.2.0.15, Decrypter 3.5.4.0 and image burn 2.4.2.0.

Share this post


Link to post
Share on other sites

Wryter:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

Please look again as there should be at least the Policies key under CurrentVersion. As for CurrentVersion\Explorer, that's a different key and unrelated to this problem :(

The NoDriveAutoRun value allows you to disable AutoRun on certain drive letters, so if I were you I'd delete this option (you can also use TweakUI to control this in its AutoPlay section).

 

Also look in the Group Policy Editor (Start -> Run -> type gpedit.msc and hit OK) at Administrative Templates -> System -> Disable AutoPlay option, under both Computer Configuration and User Configuration.

 

too-cool:

use Google to find a DVD Shrink version that's modified to burn with ImgBurn ;)

Share this post


Link to post
Share on other sites

mmalves, et al - SIGH -

OK, I went into Regedit again - after running Registry Mechanic and another registry cleaner. They found some 14 problems, and now the CurrentVersion DOES come up - TWICE - one if full of files, the other only has one listing. The subfolder goes to Control Panel.

The top CurrentVersion, however leads to Policies (hurray!) and then to Explorer. Unfortunately, there are only two entries here: Default - REG-SZ - and (value not set)

the seond one - and rather alarming - is NoCDBurning - REG_DWORD 00x0000000.

 

Now I'm REALLY confused!

 

And about to give up. double sigh.

 

Thanks, but I just don't know where to go with all this - it's only my third time running Regedit, and I'm a bit scared of the whole thing.

 

Respectfully. . .LarryR

Share this post


Link to post
Share on other sites

Your suggestions - ALL - have been solid, and I thank you for them!

 

Just one other question and I'll get on with what's left of my life.

 

How many, and where, NoDriveTypeAutoRun values should there be?

 

There's none in HKEY_LOCAL_MACHINE - and I think there should be?

 

The Microsoft knowledge(?) base keeps writing about the Autorun "entries," so I guess there should be more than one place where they show up in the registry?

 

If anyone can just post the location - I'll try to enter them and see how quickly I can crash my machine! (GRIN)

 

Respectfully. . .LarryR

 

BTW - I used ImgBurn SUCCESSFULLY three times last night. What a great program! I'm glad I "killed" the Dell-supplied Sonic burning program that always hung up.

Edited by Wryter

Share this post


Link to post
Share on other sites

I just happened to notice this thread and after I install Imgburn I too get some weird side effects in my AutoPlay. It only does it on certain discs, but in the AutoPlay menu XP has where you select what you want to do I have an entry with weird text. I can't remember the exact wording, but it contains the text "unrecognized", "unspecified", or "unregistered"...one of the "un" words and I believe some bracket [] characters and/or <> characters in it. It usually doesn't go away, but seems to be linked with installing Imgburn.

Share this post


Link to post
Share on other sites

It should be easy to find the cause of problems like that, just look in regedit at the following key.

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers

 

ImgBurn adds entries under 'EventHandlers'... look at the keys starting with 'Handle*' and 'Play*'.

 

Then look under 'Handlers' for the keys starting with 'ImgBurn*'.

 

I'm 99.9% positive ImgBurn isn't to blame for your problems.

 

To me it sounds like you uninstalled something and it didn't remove its autoplay handlers properly.

Share this post


Link to post
Share on other sites

Hmm, couldn't find anything wrong there that jumped out at me. I guess the next time it happens I need to look at the Content/Event Type so I know which key the problem resides in.

Share this post


Link to post
Share on other sites

What I've seen in here might help me. After I installed Vista as an upgrade to XP, autoplay just quit on both of my drives.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.