Jump to content

Crash when hitting Win+E (Explorer) during burn-process


Recommended Posts

When [inserting a usb-stick and] hitting win+E (Explorer) during a burn process the explorer crahes. The displayed writing rate in ImgBurn drops to 0 and does not recover (under Vista Sp1, ImgBurn

Both (explorer and ImgBurn) cannot be closed except via task-manger (by luck - in most cases only a hard reset helps, sometimes even the task-manager does not pop up when requested to kill Explorer or ImgBurn ... )

A reboot is needed in each case to release the device (dvd-rom does not react on eject)


Problem might be related to exclusive lock of Device ...

... a vista-bug or ImgBurn ... ?

Link to comment
Share on other sites

The lock is supposed to prevent things like Explorer from accessing the drive when it's being written to. I assume you let the program lock the drive? Which I/O interface do you use?


By the sounds of it your entire I/O subsystem is hanging rather than just ImgBurn.


Does everything get hung up like that if you just do Win+E without inserting a USB stick?

Link to comment
Share on other sites

Tested again without inserting a USB-Stick


Yes, everything hangs up when hitting win+E, ImgBurn seems to recover sometimes but is not able to proceed correctly, I attached the log of my last try.


To reproduce: Write files to disk -> after writing the lead-in hitting win+E

-> explorer does not fully show up, vista declares explorer does not respond any more, ImgBurn does not write any more, rate drops to 0

... [letting time pass does not seem to change anything]...

-> launching task manager (wdm.exe seems 2nd biggest process (next to ImgBurn) in amount of memory and cpu usage -> kill wdm.exe)

-> klicking on explorer again -> vista tries to restart explorer ... layout/explorer completely broken

-> ImgBurn somehow pronounces many retries in writing

-> closing ImgBurn lead to some error message ...


I'm using the default installation (no config change to default), i.e. I/O is SPTI


Tried to check other I/O-interfaces, but they don't seem to be shiped by default installation ...


Link to comment
Share on other sites

tested it further:

  • 1. on a different computer with win-xp SP3 installed, nearly same software setup (except Nero instead of Roxio installed)
    2. in a virtual machine running on the original vista-computer [with the same device that led to a crash under vista], OS in VM is win-xp SP3 (clean install)

-> hitting win+E causes no problems and works fine over there in both setups


-> so this might be a vista issue, a device(-driver) problem or an interference with roxio (although not running roxio at the same time ...)


any clue?

Edited by jogi
Link to comment
Share on other sites

It must be a device/filter driver issue because it doesn't happen on my Vista install.


Explorer opens up instantly and even when I double click on the drive ImgBurn is in the process of writing to, it just brings up a box saying the drive is currently in use - which is exactly what I'd expect to happen.


Here's another test for you... start burning something (a DVD+RW is fine) and then open a 2nd instance of ImgBurn.


Do you get an 'access denied' message in the log window for the drive you're burning to in the other instance of ImgBurn? (or does that just make everything hang too?!)

Link to comment
Share on other sites

tried it with the same medium/project-setup - just got an access denied in the 2nd instance of ImgBurn, but nothing hangs ...



I 21:49:27 Searching for SCSI / ATAPI devices...

E 21:49:29 CreateFile Failed! - Device: '\\.\CdRom0' (E:)

E 21:49:29 Reason: Zugriff verweigert

W 21:49:29 Errors were encountered when trying to access a drive.

W 21:49:29 This drive will not be visible in the program.



any ideas how to trace back/track down the driver/software interfering with ImgBurn and causing the explorer-crash?

Link to comment
Share on other sites

What do you have installed that's anything to do with optical drives (real or virtual), burning, reading, making images, manipulating images etc?


What do you have in your 'Filter Driver' list (look in the Tools menu) ?


It would appear that something at a lower level than Explorer (or at least something that doesn't play by the rules) is being called/triggered when you open an explorer window and it's totally hanging the bus. ImgBurn is just getting caught in the crossfire. You'll just have to go through all the applications you have installed on your machine and find out which one it is.

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.