Jump to content

Installer Bug for ImgBurn v2.5.0.0


Recommended Posts

Good Afternoon,

I've been attempting to install ImgBurn on a system for a standard user on a Windows XP SP3 system. I logged in as a domain admin & installed ImgBurn with "Install for All Users" & "Enable SPTI access for All Users" enabled. After the installation I rebooted, logged in as admin and tested with everything passing. I then logged in as a standard user and tested but it FAILED. I received the 'You need Administrative privileges to use SPTI' error when I launched it.


I then attempted to follow the manual instructions based off of the FAQ (http://forum.imgburn.com/index.php?showtopic=59) but had the same results.


To make a long story short, I finally identified (by testing on another clean system that never had ImgBurn installed on it) that before you run the setup the registry value [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] "allocatecdroms" setting exists as a "REG_SZ" value. When you select the "Enable SPTI access for All Users" option in the ImgBurn installer, it changes it to a REG_DWORD value. This caused the policy/registry setting to not be applied properly ( see http://technet.microsoft.com/en-gb/library/cc957388.aspx ).


Hope this information will make things smother for the installer. Maybe I'm the only one experiencing this but if someone can confirm...




Link to comment
Share on other sites

Hello !



I installed ImgBurn on 2 computers :

-Windows Vista (64 bit).

-Windows 7 (64 bit).


I also use the "Enable SPTI access for All Users" setting.

I checked, the registry value is also wrong (but seem to be placed elsewhere), but it doesn't seem to make any problem, I can burn while logged in as a standard user.


Is it expected that this bug doesn't affect Vista and Seven ?

Or is there some hidden problem that I will find later ?




Edited by imgpaul
Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.