Jump to content

Hang up on "logical devices in process of becoming ready"


Recommended Posts

I am new to this site so go easy please. I have been searching for a couple hours now to find an answer to my problem, but I just dont know where to look.


My problem is that whenever I try to burn an image to disc, IMGBURN (v 2.5) seems to hang up when I insert a blank DVD.


"logical devices in process of becoming ready" is the last thing it says before hanging up and I have tried to be patient, waiting as long as half an hour, but nothing comes up on the log. I end up having to reboot as it just sits and makes a weird noise and even after hitting cancel. I have waited as long as twenty minutes after hitting cancel. I just end up rebooting and ejecting the blank DVD while OS is coming on line.


I am thinking something to do with drive as I added external DVD drive and it works fine in all modes of imgburn.


I have made sure my DVD driver (in question) is updated and have tried uninstalling both the DVD driver, and imgburn, then reinstalling. But no success.



Any links or advice would be great, I just have no idea where to look without some hint in the log.

Edited by devildog93
Link to comment
Share on other sites

It sounds like your drive is broken or simply doesn't support burning DVD's (hence why it never becomes 'ready' and makes weird noises).


It does support burning DVD's, but yeah, maybe it is just broken. I will try with other programs that have a burn function and go from there.



Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.