Jump to content

No Writers Detected


Recommended Posts

I know this isn't really a way to solve the problem, but i had many issues with the new imgburn 2.5

I am running windows vista 64 bit with an amd processor. anytime i want to burn something iso wise, i use imgburn. However, it asked me to upgrade. I upgrated and now i get dvd writer not found. I tried deleting my upper and lower bounds and tried to uninstall my driver for the dvd drive, but it always seemed to randomly disappear. Only thing that brought it back, was a restart or microsofts FIxIt tool. I contacted gateway support and was told to do a factory restore. I thought giving it one last go before i did that. So i deleted all my dvd programs except imgburn and tried to burn. Same problem happened. I decided a factory restore was my issue because my registry was corrupted. (The cd drive works in the BIOS and in Ubuntu.)

After restoring my computer, i deleted all the preloaded crap like windows live. I then put IMGBurn back on my PC, problem still occured. My dvd drive disappeard. I did a system restore to when i didnt instal imgburn and burned the iso with MagicIso. it worked. So i came to the conclusion IMgburn was my issue. I reinstalled imgburn, but version All is good. I can burn and my dvd drive won't just randomly disappear. If your interested, Here is my Dvd Drive: Hitachi HTS543232L9A300 ATA Device. I am on a

Gateway M-1631U

Processor: AMD Turion 64 X2 Mobile Technology TL-60, 2000 Mhz, 2 Core(s), 2 Logical Processor(s)

BIOS Version/Date Phoenix Technologies LTD 9D.05, 5/23/2008

OS Name Microsoft® Windows Vista™ Home Premium

Version 6.0.6001 Service Pack 1 Build 6001



Just thought I would share if anyone else had the problem. Also I love Imgburn and I will continue to use it, eventhough I cannot update it.

Link to comment
Share on other sites

The only thing that changed in that respect is the method used to detect drives. Just go into the I/O tab and change the 'SPTI - Device Enumeration Method' to 'Device Class'.


No idea what's messed up on your system to stop the default one from working.


It would have helped if you'd posted a log file.

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.