Jump to content

Device not detected when Audio CD is inserted (Linux/Wine)


Recommended Posts

System: Ubuntu 10.04 x86

ImgBurn : Latest

Wine: 1.1.42


ImgBurn is working fine with data CDs and DVDs. The problem is with Audio CDs. Whenever I insert an Audio CD, it says "No devices detected!"

I have changed the wnaspi32.dll for a native Windows version, and still get this error.

Is this a showstopper or just a tiny configuration I am missing.


And Yes, I have previously detected all the drives in WineConfig, including the CDROM drive (otherwise it wouldn't work with data cd, right?)


Thanks for answers.

Link to comment
Share on other sites

I assume you've also changed the I/O interface within ImgBurn to the ASPI option?


The setup you mention there is working ok for me (with ASPI set).


Wine just doesn't always report the drives when using SPTI... there's nothing I can do about that I'm afraid.

Link to comment
Share on other sites

Thanks LUK, now it worked.

Yes, STPI does not always recognize the drive, specially Audio CDs.


I had previously installed a wnaspi32.dll as a native DLL, but it did not work with ImgBurn set to ASPI (WNASPI32.DLL), however, I deleted the wnaspi32.dll from system32 wine drive_c folder; after this I copied another dummy dll and (all DLLs are identical dummy files) renamed it to wnaspi32.dll - THEN IT WORKED with option ASPI set, like you said.


This is great. Been using Brasero and K3B but ImgBurn is one of the apps I mosltly miss from Windoze, along with foobar2000.


Let us pray that you may wake up in love with the world and port this application to Linux, someday :-)

Edited by DjBR
Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.