Jump to content

CD audio analyse freeze


Recommended Posts



It seems I have the same problem with the guy in this topic


(but I can't reply there)


I attempt to create an image of an old audio replicated CD (with some littles scratchs).

Imgburn 2.5.10 fails on track 2 : it just freezes (no error message after a long time)


I manage to create a bin image with Isobuster so it's OK.

But does it prove that my CD is OK ? (My client wants to be sure before duplicate CD from image).


So my question is simple : does the problem come from ImgBurn or the disc ?


Thank you


from Paris


Edited by Kasiorn
Link to comment
Share on other sites

  • 1 month later...

Fwiw, I had this prob with prior version but also with 252. The image is created from CD disk and can be burned but during verify it locks up at Track 3 while analyzing tracks. I burned the same image file a coule of times with same result and then recreated the image file and tried again that way -- same result. I tried a couple of times using Verify directly from the Menu but same result. I tested the disks that were burned and all play fine. Not knocking the prog; it's great. I attached the log in case that is of use. If I can do something to help with the issue, let me know.




Edited by shieber
Link to comment
Share on other sites

  • 2 weeks later...

<AOL> Me too :) </AOL>


Just in case it helps any debugging going on, I too have this problem: I'm trying to use ImgBurn on a fully-patched WinXP box to copy an audio CD I burned on another PC using Roxio - the CD contains 3 audio tracks sourced from WAV files (radio recordings using Audacity), burned in track-at-once mode (hence 2-second gaps will be present), and finalised.


ImgBurn always hangs up after a couple of seconds while "Analysing tracks". The last status bar message is always "Analysing Tracks... (Session 1, Track 2)". I actually left it running for 9 hours at one point but nothing changed. The CD drive activity light stays on continuously.


The CD actually plays fine, both on the PC and in a domestic CD player. The media is a Verbatim <barf> "Extra Protection" disc (actually made by CMC) but they work fine for my other scratch purposes so long as they're burned slowly (I'm using them up).


It's a long time since I've used IB to copy audio but I know it used to work fine at earlier releases.


The attached log is from a "Verify Disc" run (not against image file) with debug tracing enabled, which fails in the same way.


From a quick look at the log it seems ImgBurn is getting lost, and reading sector numbers which increase and then decrease endlessly. If there's any more info you want I'm happy to supply.


Link to comment
Share on other sites

It's just trying to get the sub-channel info for a specific sector - but your drive is unable to provide it.


Getting the sub-channel info for a specific sector isn't an exact science, so the program has to allow for your drive returning stuff it doesn't want and retry (sometimes increasing / decreasing the LBA) in order to get it.


There's code present to detect looping etc but it needs a lot of tweaking to cover all the eventualities.

Link to comment
Share on other sites

It's just trying to get the sub-channel info for a specific sector - but your drive is unable to provide it ... There's code present to detect looping etc but it needs a lot of tweaking to cover all the eventualities.

So .. er .... the algorithm changed in the newer releases ?

And the drive this user has is capable of providing the data my drive can't ? :wacko:

(They say they are using IB to create image files from audio CDs.)


Just a data point: I've now gone back through the last few ImgBurn releases till I got to one that works. For my Asus DRW-1608P2S drive :

  • IB is the last one that works.
  • IB is the first one that doesn't work.

(I've actually now gone back to which I seem to recall worked fine for me back in the day - for as long as I want to copy audio discs anyway.)

Link to comment
Share on other sites

Another data point: I've discovered the other optical drive in my workstation - a DVDROM drive, Asus DVD-E616P2 - reads the same audio CD just fine with all versions of ImgBurn right up to


I should have thought of trying this before :doh:, but have always used the DVDRW drive because its alleged capabilities are greater than the DVDROM drive. I've attached screenshots of IB's own Capabilities report for the two drives.


I guess that despite this, the DVDROM drive must be able to read the subchannel data you mentioned, while the DVDRW drive can't


The older 'working' versions are fine, they just won't be as accurate at detecting pregaps (index 0) as the later versions.

Interesting you mention that - the CUE file created by IB to go with the .BIN file created when I read this disc is like this :


FILE "Image.bin" BINARY
   INDEX 01 00:00:00
   INDEX 00 57:26:52
   INDEX 01 57:28:51
   INDEX 01 63:58:00

The IB log for this read operation looks like this :


I 20:39:25 ImgBurn Version started!
I 20:39:25 Microsoft Windows XP Professional (5.1, Build 2600 : Service Pack 3)
I 20:39:25 Total Physical Memory: 1,048,048 KB  -  Available: 612,036 KB
I 20:39:25 Initialising SPTI...
I 20:39:25 Searching for SCSI / ATAPI devices...
I 20:39:25 -> Drive 1 - Info: ASUS DRW-1608P2S 1.39 (F:) (ATA)
I 20:39:25 -> Drive 2 - Info: ASUS DVD-E616P2 1.08 (E:) (ATA)
I 20:39:25 Found 1 DVD-ROM and 1 DVD±RW/RAM!
I 20:40:46 Operation Started!
I 20:40:46 Source Device: [1:0:0] ASUS DVD-E616P2 1.08 (E:) (ATA)
I 20:40:46 Source Media Type: CD-ROM
I 20:40:46 Source Media Sectors: 319,808
I 20:40:46 Source Media Size: 752,188,416 bytes
I 20:40:46 Source Media File System(s): None
I 20:40:46 Read Speed (Data/Audio): MAX / 8x
I 20:40:46 Destination File: N:\Image.bin
I 20:40:46 Destination Free Space: 4,452,859,904 Bytes (4,348,496 KB) (4,246 MB) (4 GB)
I 20:40:46 Destination File System: NTFS
I 20:40:46 File Splitting: Auto
I 20:40:59 Reading Session 1 of 1... (3 Tracks, LBA: 0 - 319807)
I 20:40:59 Reading Track 1 of 3... (AUDIO/2352, LBA: 0 - 258501)
I 20:50:00 Reading Track 2 of 3... (AUDIO/2352, LBA: 258502 - 287849)
I 20:50:45 Reading Track 3 of 3... (AUDIO/2352, LBA: 287850 - 319807)
I 20:51:33 Exporting Graph Data...
I 20:51:33 Graph Data File: N:\ASUS_DVD-E616P2_1.08_29-NOVEMBER-2010_20-40_N-A.ibg
I 20:51:33 Export Successfully Completed!
I 20:51:33 Operation Successfully Completed! - Duration: 00:10:46
I 20:51:33 Average Read Rate: 1,137 KB/s (6.6x) - Maximum Read Rate: 1,615 KB/s (9.4x)

Two questions if I may : :worthy:

  • What's the significance of the "INDEX 00" entry in the CUE file ? There was nothing weird that I can think of about the 3 WAV files that provided the source for the audio tracks.
  • I'm now thinking of buying a new DVDRW drive that doesn't have this issue - what capability description should I be looking for to get a drive that can usefully read the subchannel data ?




Link to comment
Share on other sites

I'm sure they all read sub-channel, it's just some let me read it more easily that others.


Some give you exactly what you ask for, some give you something roughly around that area - and that's when the program has to mess around jumping forward and backward (LBA wise) to try and get the actual info it asked for in the first place.


Index 01 is where players consider a track starts (i.e. when you skip tracks on a CD player with the remote etc, that's where it jumps to). There can be data before Index 01 (but that's still physically part of the that track), and that's known as pregap or Index 00.


You could hide an entire song in the pregap of a track... and some discs do exactly that. Think 'hidden bonus tracks' - normally you have to play the disc and then hit the rewind button to get at them.


So whilst the TOC of a disc might say:


Track 1 - Start LBA (i.e. Index 01 LBA): 0

Track 2 - Start LBA (i.e. Index 01 LBA): 1000

Track 3 - Start LBA (i.e. Index 01 LBA): 2000


In reality it might be:


Track 1 - REAL Start LBA (i.e. Index 00 LBA): -150

Track 2 - REAL Start LBA (i.e. Index 00 LBA): 850

Track 3 - REAL Start LBA (i.e. Index 00 LBA): 1990


The only way to find out what track a given LBA truly belongs to is to try and read the sub-channel data for it.

Link to comment
Share on other sites

  • 3 weeks later...

Ok so now you need to wait for, which may or may not fix the issue for you.

http://www.imgburn.com/index.php?act=changelog ( section) :


Fixed: 2nd attempt at fixing the issue where the program gets stuck 'Analysing Tracks' (basically, just an issue with Audio CDs).

Just FYI, does not fix this problem as exhibited by the one affected drive on my PC. Do you want another debug trace ?



Link to comment
Share on other sites


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.