Jump to content

Synchronising Cache stuck and Raid


Recommended Posts

Hello everyone, I just want to post my experience with a little problem I had and was able to resolve it by doing a search. I have a Gigabyte motherboard with the AMD 785G chipset and 2 samsung sata dvd burners. They always worked perfectly with ImgBurn except when I installed 2 hard drives and enabled the raid controller in the bios for a Raid 1 array and the 2 dvd burners are now working in Raid mode and not IDE because if I want to make a Raid array the sata ports must be in Raid mode. Burning an ISO in this mode as soon as the writing was finished it would get stuck in "synchronizing cache" and I had to do a reset to the pc to get the disc out.


What I did was go to tools, settings, I/O tab and enabled "Don't Use Immediate I/O" as explained in this post: http://forum.imgburn.com/index.php?showtopic=13830


By the way I made 2 coasters but I found out that if this happens to you you can "finish/fix" your disc. After you restart, with the disc inserted go to any mode in the main menu, tools, then drive, close track, after that close disc. DO NOT close session after closing the track because you will be opening another session on the disc (or so it seems). That should do it.


It seems that those of you that are running drives in Raid mode that have the same problem may find it helpful so try it out.


What I'd like to know is what exactly the "Don't Use Immediate I/O" setting does and why isn't it enabled by default?. I did read the ImgBurn settings guide but I didn't really understand what it does. Does other burning software that doesn't get stuck after writing have Immediate I/O "disable"?


Thanks everyone.

Edited by Sisk0
Link to comment
Share on other sites

Ah sorry, missed the 'AMD' bit :)


Actually I edited my original post after you replied as to avoid confusion of future readers lol. I know I didn't post my full specs and I can do so if anyone needs it. I'd like to see some responses from users that have burners in sata raid mode. Anyone else had that problem and enabled the option and got it working?

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.