Jump to content

Hang or very slow with certain discs


Recommended Posts

Hi. Here is my setup

Recent asus dvd drive, and recent usb dvd drive.

Windows 7 x64

I am having trouble with one disc when I try to do anything with it(create iso, verify) where it will get to the reading sectors portion and freeze. I messes up my whole computer, as when I click stop, img burn prompts me and I click yes please stop. Then the log outputs some more, and freezes. I let my computer sit for 2 hours, and eventually tried to end process. Would not. Also, started to mess with other programs and cause explorer.exe to freeze as well as other weird stuff. This is the only disc doing this, and it only happens when in my asus dvd drive and with img burn. I can do everything fine from the USB dvd drive. I have ripped plenty dvds all day to my computer with no issue. I used another program called dvd recorder and it worked great ripping this disc to iso from the asus drive. The disc I am ripping is a DVD and fairly new. The fact that it works with another program leads me to believe this is a issue with img burn. I had to shut down my computer with the button held in to get the drive to open. Windows unable to shutdown when this happened. Please let me know if you need any more information.

Edited by aknewhope
Link to comment
Share on other sites

I 13:32:41 Operation Started!

I 13:32:41 Source Device: [1:1:0] ASUS DRW-24B1ST c 1.05 (F:) (SATA)

I 13:32:41 Source Media Type: CD-R (Disc ID: 97m24s16f, Sony Corp.)

I 13:32:41 Source Media Supported Read Speeds: 4x, 8x, 10x, 16x, 24x, 32x, 40x, 48x

I 13:32:41 Source Media Supported Write Speeds: 8x, 16x, 24x, 32x

I 13:32:41 Source Media Sectors: 301,788

I 13:32:41 Source Media Size: 618,061,824 bytes

I 13:32:41 Source Media Volume Identifier: GRTMPVOL_EN

I 13:32:41 Source Media Volume Set Identifier: GRTMPVOL_EN

I 13:32:41 Source Media Application Identifier: CDIMAGE 2.52 (03/09/2004 TM)

I 13:32:41 Source Media File System(s): ISO9660 (Bootable)

I 13:32:41 Read Speed (Data/Audio): 16x / 16x

I 13:32:41 Destination File: E:\iso_images\microsoft_win-xp_pro_x32_SP3.iso

I 13:32:41 Destination Free Space: 729,526,874,112 Bytes (712,428,588.00 KB) (695,731.04 MB) (679.42 GB)

I 13:32:41 Destination File System: NTFS

I 13:32:41 File Splitting: Auto

I 13:36:47 Abort Request Acknowledged


This is where it was happening. I had to hard restart my computer when it happened about 3 times, so I don't see all the log info from all 4 times I tried it.

And I could do it again, but I don't like hard restarting my computer. Let me know if you need me to. As you can see in the image, it was verifying sectors, but It only made it through 32 in 2 min and I let it run for 2 hours, and was still verifying. Not even 2% done verifying before the iso rip. And I tried to stop, and everything froze up and I had to hard restart my computer.

Edited by aknewhope
Link to comment
Share on other sites

If 'File Splitting: Auto' is the last line in the log window when it's freezing, what does it say in the status bar? That'll tell us what the program actually thinks it's doing - not everything gets logged.


I don't know what's happening in post #3. The program is only asking the drive to read a range of sectors and it seems to be having trouble doing that.


Can you please right click the drive selection box and pick 'Family Tree'. Close the prompt and then copy + paste everything from the log window.

Link to comment
Share on other sites

  • 1 month later...

Sorry about the delay. I am doing this from work, so I can't always be doing these types of things. Ok, so today I inserted a HP printer DVD, and selected burn disc to image file at 4x x 4x. Same issue.

  • First time it stuck on "Reading Media Catalog Number..." while the log shows File splitting auto.
  • Second time, it got stuck on "Reading Sectors" in the status bar, and "Reading track 1 of 1" in the log.
  • Third time got the "Reading Media Catalog Number...", while the log shows File splitting auto.

Here are some images, and the family tree you wanted for my Asus drive. Keep in mind, this works fine with the same drive and ISO recorder(software). Thanks, and please let me know if you need me to do anything else such as test more configurations, or more screenshots of the program. One the image name img-burn4, I have the full log from the three trys, but the first is chopped off at the top.


Some info about my setup.


-intel DZ68BC motherboard

2 onboard SATA R3 ports. (I use those for SSD boot drives.)

2 onboard SATA R3 provided by Marvell controller.

4 onboard SATA R2 ports. (I use for spinning hard drives for storage.)


As you can see, the drive is hooked up through the Marvell SATA R3 port. Not sure if that has anything to do with it. I have the correct drivers installed, and other discs work great sometimes, especially with ISO Recorder as stated above.




***I am trying to abort out of try #3 and it's at 12 minutes and still waiting. It's locking up my computer management console, USB drives are not showing up when plugged in, etc...***





Edited by aknewhope
Link to comment
Share on other sites

As you can see, the drive is hooked up through the Marvell SATA R3 port. Not sure if that has anything to do with it.


That is no doubt the issue here. 3rd party controllers (apart from Silicon Image chipset ones) often have problems with optical / ATAPI devices.


I/O commands should either succeed or fail... they're not meant to get stuck so that's purely a driver/controller issue.


I have a Z68 motherboard at home myself and that too has an (unused) Marvell controller on it (I made sure to connect my optical drives to the SATA2 ports on the Intel controller). I'll give it a spin when I next get a chance and see if mine has the same problem (with various drives). That won't be for a week or so though.

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.