Jump to content

CD-ROM device not working in Windows - but does in ImgBurn.


Recommended Posts

I'm running Windows XP, have had the LiteOn iHAS324 F drive hooked to a PCI card with extra SATA-channels.
After having some troubles with the PCI card (Sil3114 based) as well as the mentioned iHAS324 not being identified by Windows correctly I bought a new PCI-card, (Sil3124 based, http://www.lycom.com.tw/ST124.htm ) and hoped things would improve. 
The iHAS324 shows up in BIOS, I can boot from it, ImgBurn runs using the ASPI interface only - so no problems there, but device settings in Windows shows it with a yellow disc with a black exclamation mark saying it can't load the driver (code 39). So that's the exact same problem as the previous PCI-card - no improvement there. It's identified as a SCSI device (it's not but that's how it's seen) bus 3, target id 0, lun 0. I have tried the other three connectors on the PCI-card but to no avail. I don't get any device letter in Windows so usage is a bit limited.

I have downloaded the latest drivers for the PCI card which is made for Windows XP, I have downloaded and reinstalled ASPI drivers and I'm at my 7th reboot for the day trying to remove devices and let the plug'n'play find them again. I have tried finding drivers from the Windows XP install CD... but I don't really know what to look for. Best option yet (but not working) was when I got these to choose from:
CD-ROM Drive (force CDDA accurate)
CD-ROM Drive (force CDDA inaccurate)
CD-ROM Drive (force IMAPI disable)
CD-ROM Drive (IMAPI settings 0,1)
... and  eleven more like this with different numbers 0,1-5 and 1,1-5.

May I should try and locate "SCSI" drivers instead?

So I thought, as you guys are wizards with CD-ROM unit related problems, I'd ask here. 
Seems to be a Windows related driver problem, a register entry missing, a Windows driver file lost? 
Can't I make Windows use ASPI interface as well or somehow fix the SPTI interface or whatever Windows usually use?

I know buying a new computer or reinstalling windows might solve the problem... it probably will, but another workaround would be preferable. 

Link to comment
Share on other sites

Seems the data on the boot drive must have gotten corrupted, possibly from power problems, bad SATA-cables, SATA power connectors or the SiI3114 card previously used. 
PSU replaced, SiI3124 card in place and Windows reinstalled - works fine again. 

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.