Jump to content

Can't create bootable grub2 image


Recommended Posts

Hi there!

Since the search only pointed to this topic and I couldn't reply to it, I'm creating a new one.

What's new on the front? 10 years later and I've run into a similar problem.

I'm trying to rebuild/remaster the k3os-amd64.iso

  • I've copied the contents of the ISO into folder "x:\k3os-amd64"
    • tried extracting with 7-zip, as well as mounting via Windows and copying from the virtual drive
  • edited some files unrelated to grub or boot
  • started up ImgBurn
  • selected "Create image file from files/folders"
  • added folder "x:\k3os-amd64\" via "Browse for a folder..."
  • switched to the tab "Advanced/Bootable Disc"
  • activated "Make Image Bootable"
  • selected Boot Image "x:\k3os-amd64\boot\grub\i386-pc\eltorito.img"
  • switched Platform ID to "UEFI"
  • checked "Patch Boot Information Table"
  • clicked "Build"

The resulting ISO file wouldn't let my k3os vm boot, while the original, unmodified k3os-amd64.iso works without problems.

Are there any options I'm missing, am I using it wrong or won't this ever get fixed?

Thanks a lot for ImgBurn and in advance for any help.

Link to comment
Share on other sites

Thanks for your reply.

However neither with Platform ID 80x86 and the eltorito.img nor with UEFI and the efi.img I'm able to boot from the created image.

I also tried checking and unchecking the "Patch Boot Information Table" - it won't boot.

Any more information I could give you to pinpoint the culprit?


Edit: I also tried the "Extract Boot Image" option with the virtual drive, created by mounting the image through Windows (10)

Edit 2: If it makes any difference, I'm using Hyper-V for the VM, though I doubt, it does, since the original image works just fine. I believe Hyper-V uses EFI.

Edited by u5soft
Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.