Jump to content

Disc activity measurement issue?

Robert Sirre

Recommended Posts

Hi there.


I think I've found a bug in ImgBurn.


I was burning a DVD from an ISO image. As as I was doing some other i/o intense operations, at some point my hard disk did not keep up with the burning process. ImgBurn then halted the process, while displaying that it was waiting for the disk activity to reach a target level (which was marked as 1). I waited quite some time (while disk fluctuated between 0,5 and 50), in the mean time having shut down all my other programs that might cause additional disk activity.


After some time, I checked out what was causing the disk activity. The permance monitor then told me it was ImgBurn itself, reading my ISO. As it was not filling up any more buffers (in the program, not my hardware buffer), this seemed to go nowhere, so I had to cancel the burning process, and discard the DVD.


I you don't mind I have not tried to reproduce the situation.


My specs, if applicable:


8 speed blueray/dvd burner (Optiarc)

Vista Ultimate x64

4 Gb RAM

Intel core duo 2GHz


Hope this helps. Thanks for a otherwise great and friendly program!

Link to comment
Share on other sites

When buffer recovery kicks in the first thing ImgBurn does is totally fill it's own buffer... after that it can't possibly be doing any more 'reading'.


When that's done it waits for the average queue length to drop to the desired value.


So basically, it's not ImgBurn that's keeping it high.

Link to comment
Share on other sites

  • 1 month later...

I noticed the same problem on 3 different hardware platform, to me it seem that imgburn always keep the buffer by reading immediately small chinks of data from the disk (correct me if i'm wrong); then it happen that if i touch other datas on the disk or launch any program windows goes crazy and the disk start seeking heavily making the data trasnfer going very slow with all the trouble you can expect (and the disk is very noisy while this is happening).

So when i start to write a dvd or a bd-r i just have to not touch the pc and eventually disable the antivirus resident shield.

Time ago i was able to burn up to 3 dvd at 4x at the same time using a well know burning software and two usb burner, however i'm using only imgburn from a lot of time because i like it more and it's free keeping with that problem, but if it can be solved i'll enjoy gaming/working and burning at the same time (burn a bdrom keep you pc busy for a lot of time).

Maybe i do samething wrong on my settings? I usually turn off indexing, enable NtfsDisableLastAccessUpdate activate and use always 4k ntfs block size, tested chipsets where 865G(old ich5) P35 and Ati_RS600, hdd are different but the issue it's the same everywhere. generally i have very good transfers on test while the hdd doesn't seek crazily, like 70mb/s disk2disk and 35mb/s network transfer; only this abnormal problem with seeking;

also, can i tweak imgburn settings so it read larg chunk of data and wait a while before filling the buffer? if so i can tell if samething change.


Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.