Jump to content

IMGBurn freeze with multiple Bluray drives


Recommended Posts

XP 2

Twin BluRay drives


LiteOn iHBS212


If either drive is installed separately they work just fine when burning. When both are installed if an attempt to burn is made with either unit the burn freezes at Change Book Type commands after reporting a successful setting of speed. The process can be aborted but the unit remains frozen and even notepad wont respond to any command when the freeze happens (I was trying to log observations). The ImgBurn log only shows the successful speed set then the abort command. The application will not close and it has been necessary to hard reboot as the shutdown commands won't proceed.


Also noted is that Nero can use either drive to record and does not seize up but once the freeze has happened Nero cannot access the affected drive either.

Link to comment
Share on other sites

ImgBurn is only ever waiting for your system to process the command. Your system (and its drivers) is the thing having trouble with both drives being connected and getting hung up processing commands, not the program.


Mine works fine with 15 physical drives (6 of which are Blu-ray) and 3 virtual ones connected all at the same time.

Link to comment
Share on other sites

I have 5 in the PC case and 2 of these that are full...







<thread hijack alert>


Hmm... that's an interesting bit of hardware. I wonder how well the 9 bay version of this thingy would work as a NAS/file storage unit filled with harddrives instead? I need to replace my current file servers but keeping everything cool would appear to be the biggest problem with the Addonics case.




What do you think? I'm open to suggestions.... from anyone...



EDIT: I just checked the homepage for this thing and I see all sorts of configuration options. The biggest worry I have is data security. I keep a backup of everything - which means I'll need two of these things. Lightning, what's your professional opinion of these as a NAS?

Link to comment
Share on other sites

If you actually read what LUK said above you'd have concluded that the problem is with something on your system and we can only help so far.


Maybe if you posted a Hardware log (right-click the Hardware branch) from SIW or similar detailed hardware log then we could try and help you find what driver / configuration / software could be causing that.

Link to comment
Share on other sites

It's a joy that all of you are measuring your hardware with each other, but is this as useful as help gets?



Ahh.... sardonic wit. How delightful. See the pink bit at the top of the page? I suggest you focus on following basic instructions prior to subjecting we peasants to your plainly obvious literary gift and poor punctuation.

Link to comment
Share on other sites

I included the info that was gleaned from the log in my first comments as it looked very clean to me. I may be mistaken as I do little hardware debugging and could miss something. I understand fully that the problem is on my end but need some guidance on a start point.


Here is the most recent part of the log. ImgBurn-brief.log There are much older entries as I have been using the app for quite a while and the hardware has changed but these show the recent behavior.


The first entry shows a successful burn but the verify froze. This was a new change in behavior as the previous freezes were before the burn started.


The third entry shows the freeze at the set book type, the log records the speed being set. It has done this several times but he log only shows the one incident.


The last is a successful burn with one of the drives disconnected.


The only item that I changed in the time between the burn freeze and the verify freeze was to retire some old shares that referenced the drive letter now occupied by the second optical drive and I am unsure of the relationship if any to the acute problem.


If this is a hardware problem or a driver issue but it is not showing itself elsewhere, any advice on where to begin the hunt?

Link to comment
Share on other sites

The Lite-On has a more recent firmware (5L08) update than yours installed (5L03) http://www.firmwarehq.com/Lite-On/iHBS212%2B2/files.html


Also rightclick on LG drive and select Check for firmware updates... or Capabilities to show the full firmware version.


Here is the latest firmware for LG (note the -A9) http://www.firmwarehq.com/LG/WH10LS30/files.html


Try this site http://www.ma-config.com/ to see if it finds more recent drivers than you currently have installed.

Link to comment
Share on other sites

to ianymaty


Thanks for the leads. I have been to the manufacturers websites multiple times and the firmware was not listed in their docs, only through the utilities so I missed it. Oh, well. I had the LG maxed out on the firmware already but the LiteOn was new and likely had to do with their internal identification issues, though whatever their fix was it seems to have worked. I had to install the update in safe mode. Is this a typical behavior? The LG updated during a normal session. I also reduced my memory by 2gigs as XP apparently only does 4gigs max and according to some opinions has problems when it has too much. I also increased the virtual memory page size but I doubt this had any effect as I was messing with another piece of software (old DVD shrink with the "out of memory error." Didn't help that app either.


Regardless, I just had a successful burn and verify with the units and they worked. I will run ImgBurn through it paces tomorrow and see if the fix holds up.



I read that you have a bunch of optical drives in your various machines, have you run into the issue with XP and identical optical drives not being properly addressed and recognized (SATA)? http://www.computing.net/answers/windows-xp/two-new-dvd-drives-will-not-work-code-42/192082.html


Also, when reading the hardware info, I read that I have a lot of loaded legacy drivers. I have never examined the guts of XP in that detail, is that normal?


To mmalves, thanks for the hardware info link. It led to the update.

Link to comment
Share on other sites

Just looked at your hardware and you don't seem to be a tight-fisted hand one. :thumbup:


Did you considered runing Windows 7 on that computer?


Windows XP is old now and just cripples that computer. ;)

Link to comment
Share on other sites

I, too had a similar issue last night while trying to backup data.



Microboards 4-bay Bluray Copywiter w/ Pioneer BDR-101A drives

Sony Accucore BDR-V1.1 2x


Can't really tell if it was media, OS or hardware-related. The burning would start alright, but on 2 occasions stopped at different points during the process. Write rate went to 0.00x and just stayed like that. Had to power cycle the Microboards tower to recover. I was able to successfully burn 2 discs under XP. So, the sequence was 1 good, 1 bad, 1 good, 1 bad.


Now that I think about it, it's probably hardware and/or OS-related, as I successfully burned what I needed to (over the network) on a Win7 machine with dual Matshita SW-5582 B110 units installed, using the same Sony media. I think the computer mode of that particular Microboards tower is a little buggy.


Just posting to show that in my situation, 2 successful burns were achieved in an XP system with multiple Bluray drives (even though I also had 2 failures.) Sticking with burning from Win7 going forward.

Link to comment
Share on other sites

I have to admit it, I will probably go with 7 soon. All of my laptops are on it and it seems to be surprisingly stable for a relatively new MS product. Networking sharing seems a little buggy at times but I am not sure if that's just a Norton "Feature" or if MS is the cause. I am a slow converter by history, I still have rock solid SCO Unix 505 P1s running for specialized apps at work. The first laptop that I set up with MS 7pro 64 bit hurt $$$ wise as all of my video and publishing apps had to be upgraded.

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.