Jump to content crashes for some users in maverick / wine 1.33


Recommended Posts

long time ImgBurn user, recently moved from XP to Ubuntu 10.10 and very pleased to see ImgBurn working under Wine!

Had 2.5.5 mostly working (sometimes issues detecting drives)

saw the changelog for 2.5.6 with WINE fixes, so updated.


Imgburn now crashes on startup at the point where it detects drives. generic error refers to appdd.winehq.com


not sure what to do?


have tried several wine 1.3x versions


weirdly. it works under my admin account, but that's no good as it needs to work for the user with the music to burn :P


any ideas appreciated. for now have rolled back to 2.5.5

Edited by Smiff
Link to comment
Share on other sites

just logged in under crashing user's account to post crashlog

interesting (?) that there are a few errors, like this is an AthlonXP not a P4, and user is not an admin.


date/time         : 2011-11-25, 20:17:44, 622ms
computer name     : study2
user name         : bob <admin>
operating system  : Windows XP Service Pack 3 build 2600
system language   : English
system up time    : 1 minute 37 seconds
program up time   : 40 seconds
processor         : Intel(R) Pentium(R) 4 CPU 2.40GHz
physical memory   : 147/1507 MB (free/total)
free disk space   : (C:) 315.44 GB
display mode      : 1440x900, 32 bit
process id        : $44
allocated memory  : 33.41 MB
executable        : ImgBurn.exe
exec. date/time   : 2011-10-03 22:51
version           :
compiled with     : BCB 2006/07
madExcept version : 3.0n
callstack crc     : $7af8d662, $88e8bbaa, $34b2efda
exception number  : 1
exception class   : EStackOverflow
exception message : EStackOverflow.

main thread ($45):
7bc70db0 +020 ntdll.dll                           wine_server_call
7bc744aa +01a ntdll.dll                           NtRaiseException
7bc70d96 +006 ntdll.dll                           wine_server_call
7bc71ee3 +007 ntdll.dll                           RtlRaiseException
7b8398dd +04d KERNEL32.dll                        RaiseException
2ce716a0 +024 netapi32.dll                        NetUseGetInfo
00516076 +10e ImgBurn.exe  Common.cpp  29452  +18 IsNetworkDriveDisconnected
004e1279 +0f9 ImgBurn.exe  Common.cpp  15075  +15 CheckDrives
006f0ee0 +620 ImgBurn.exe  ImgBurn.cpp   840  +53 Initialise
006ef32f +4cb ImgBurn.exe  ImgBurn.cpp   252 +147 WinMain
00a72fb4 +14c ImgBurn.exe                         __startup
7bc749e8 +1d8 ntdll.dll                           RtlCaptureStackBackTrace

thread $46 (TWorkerThread):
7bc78e76 +056 ntdll.dll                           NtWaitForMultipleObjects
7b86c03a +0ea KERNEL32.dll                        WaitForMultipleObjectsEx
7b86c157 +037 KERNEL32.dll                        WaitForSingleObject
009d3d72 +016 ImgBurn.exe  VirtualTrees  6249  +3 TWorkerThread.Execute
00a3eacb +02b ImgBurn.exe  madExcept              _17209
008c2494 +034 ImgBurn.exe  Classes       9877  +7 ThreadProc
008e0cc4 +028 ImgBurn.exe  system       12110 +33 ThreadWrapper
00a3e9ad +00d ImgBurn.exe  madExcept              _17207
00a3ea17 +037 ImgBurn.exe  madExcept              _17208
7bc749e8 +1d8 ntdll.dll                           RtlCaptureStackBackTrace
>> created by main thread ($45) at:
009d3c37 +023 ImgBurn.exe  VirtualTrees  6192  +1 TWorkerThread.Create

thread $26:
7bc78e76 +056 ntdll.dll              NtWaitForMultipleObjects
7bc78ec7 +037 ntdll.dll              NtWaitForSingleObject
7bc419a2 +0a2 ntdll.dll              NtFsControlFile
7bc70e6f +0df ntdll.dll              wine_server_call
7b86ea0c +08c KERNEL32.dll           ConnectNamedPipe
00a3e9ad +00d ImgBurn.exe  madExcept _17207
00a3ea17 +037 ImgBurn.exe  madExcept _17208
7bc749e8 +1d8 ntdll.dll              RtlCaptureStackBackTrace
>> created by thread $d at:
68aed6f2 +000 rpcrt4.dll

thread $d:
7bc78e76 +056 ntdll.dll              NtWaitForMultipleObjects
7b86c03a +0ea KERNEL32.dll           WaitForMultipleObjectsEx
7b86c157 +037 KERNEL32.dll           WaitForSingleObject
7b86cbe5 +015 KERNEL32.dll           SetEvent
00a3e9ad +00d ImgBurn.exe  madExcept _17207
00a3ea17 +037 ImgBurn.exe  madExcept _17208
7bc749e8 +1d8 ntdll.dll              RtlCaptureStackBackTrace
>> created by main thread ($45) at:
68ae828e +000 rpcrt4.dll

00400000 ImgBurn.exe        C:\Program Files\ImgBurn
20010000 olepro32.dll 5.0.4522.0     C:\windows\system32
20020000 userenv.dll                 C:\windows\system32
20030000 mpr.dll      5.0.2195.6611  C:\windows\system32
2b350000 usp10.dll                   C:\windows\system32
2ce60000 netapi32.dll                C:\windows\system32
2df30000 cfgmgr32.dll                C:\windows\system32
49440000 dwmapi.dll   6.0.6000.16386 C:\windows\system32
4b680000 msvfw32.dll                 C:\windows\system32
4bbb0000 setupapi.dll                C:\windows\system32
4eb20000 svrapi.dll                  C:\windows\system32
681e0000 advapi32.dll 5.1.2600.2180  C:\windows\system32
68240000 comctl32.dll 5.81.4704.1100 C:\windows\system32
68350000 user32.dll   5.1.2600.2180  C:\windows\system32
68480000 gdi32.dll       C:\windows\system32
68530000 version.dll  5.1.2600.2180  C:\windows\system32
68540000 comdlg32.dll      C:\windows\system32
68650000 shell32.dll  5.0.3900.6975  C:\windows\system32
68870000 shlwapi.dll  6.0.2800.1692  C:\windows\system32
688d0000 msacm32.dll                 C:\windows\system32
68900000 winmm.dll                   C:\windows\system32
689b0000 ole32.dll       C:\windows\system32
68ab0000 rpcrt4.dll   5.1.2600.2180  C:\windows\system32
68b30000 oleaut32.dll 6.0.6001.18000 C:\windows\system32
68c10000 wsock32.dll        C:\windows\system32
68c30000 ws2_32.dll   5.1.2600.5512  C:\windows\system32
68c60000 iphlpapi.dll 5.1.2600.2180  C:\windows\system32
68d20000 winex11.drv       C:\windows\system32
68f20000 imm32.dll    5.1.2600.2180  C:\windows\system32
68fd0000 uxtheme.dll       C:\windows\system32
692e0000 localspl.dll 5.1.2600.2180  C:\windows\system32
69f40000 winspool.drv 5.1.2600.2180  C:\windows\system32
6dde0000 shfolder.dll 6.0.2800.1106  C:\windows\system32
775e0000 dsound.dll      C:\windows\system32
78c90000 quartz.dll      C:\windows\system32
79c30000 pdh.dll                     C:\windows\system32
7af90000 spoolss.dll                 C:\windows\system32
7b810000 KERNEL32.dll 5.1.2600.2180  C:\windows\system32
7bc10000 ntdll.dll    5.1.2600.2180  C:\windows\system32

0e services.exe   0 0 normal C:\windows\system32
12 winedevice.exe 0 0 normal C:\windows\system32
1b plugplay.exe   0 0 normal C:\windows\system32
32 explorer.exe   0 0 normal C:\windows\system32
38 svchost.exe    0 0 normal C:\windows\system32
44 ImgBurn.exe    0 0 normal C:\Program Files\ImgBurn
0b winedbg.exe    0 0 normal C:\windows\system32

00516061         jz      loc_5160a8
00516063 29452   lea     ecx, [ebp-$34]
00516066         lea     eax, [ebp-4]
00516069         push    ecx
0051606a         push    1
0051606c         push    eax
0051606d         call    -$112b7e ($4034f4)     ; wstring.h.System.WideString.operator wchar_t *
00516072         pop     ecx
00516073         push    eax
00516074         push    0
00516076       > call    dword ptr [$abf378]    ; NetUseGetInfo (netapi32.dll)
0051607c 29453   test    eax, eax
0051607e         jnz     loc_5160a3
00516080 29458   mov     eax, [ebp-$34]
00516083 29460   mov     esi, [eax+$c]
00516086 29462   mov     eax, [ebp-$34]
00516089         push    eax
0051608a         call    dword ptr [$abf37c]    ; NetApiBufferFree (netapi32.dll)
00516090 29464   cmp     esi, 3
00516093         jz      loc_51609f
00516095         cmp     esi, 2

Link to comment
Share on other sites

It appears to be crashing inside an API call (NetUseGetInfo)... so it's probably a bug in Wine and therefore out of my hands.


The code in my 'IsNetworkDriveDisconnected' function hasn't changed in years.


As for the cpu and admin thing, well, don't forget that Wine is doing stuff between the app and your real OS.


I don't suppose it emulates a limited user just because you're a limited user in the real OS.




What I'm seeing in Ubuntu 10.10 / Wine 1.3.33 is this...


wine: Call from 0x7b8398e2 to unimplemented function netapi32.dll.NetUseGetInfo, aborting

wine: Unimplemented function netapi32.dll.NetUseGetInfo called at address 0x7b8398e2 (thread 002c), starting debugger...


The function is only called when you have a network share configured in the 'Wine configuration'.


Feel free to report Wine's apparent lack of an implementation of 'NetUseGetInfo' over at Wine Bugzilla - http://bugs.winehq.org/


Update 2:


Ah and the reason it's only starting to crash now is that it uses run-time dynamic linking on the netapi32.dll file (only via GetModuleHandle) and can only call the NetUseGetInfo function if it's successful.


As it happens, netapi32.dll wasn't automatically being loaded by the app (prior to and so the function never got called because GetModuleHandle would have failed (returned NULL). It can only get the handle of loaded modules.


Starting with, one of the 3rd party components loads it and so my call to GetModuleHandle(netapi32) is now successful - which then means the NetUseGetInfo function can be called.


Wine have messed up there really. They shouldn't have exported the function if there was no implementation (not even a stub) for it.

Link to comment
Share on other sites

wow thanks quick response and follow up!


so... i'm not a programmer. the reason could be that it's crashing for the users with NFS mounted home dirs, but not the admin with local home? (this is my setup).

however, the nfs filesystem should be transparent to apps?


sorry i don't know what a network share in wine config is.. is there something i can disable in wine config to stop this crash then? i tried removing all drives except the cd-rom, that didn't help.


looks like this is a legit bug, so thanks for looking into that. would a newer ubuntu version make any difference? (not really an option for me until 12.04, just curious).

Edited by Smiff
Link to comment
Share on other sites

ok i'll have another play with wine config, otherwise i'll have to carry on using 2.5.5 (and will take any Wine updates of course)

there was some other bug in wine 1.2x that forced me to update to 1.3x.. i think it wasn't detecting drives properly.


thanks again, and for all your work.

ImgBurn is the only app that can burn my .cue sheets properly! everything else i tried in ubuntu failed.

Edited by Smiff
Link to comment
Share on other sites

edit: first time i ran it after updating it didn't detect any drives, now it does, seems to work too, nice! thanks


Another problem is that the app just sort of hangs after Average Verify Rate.. it doesn't crash, you can push buttons, but if you cancel it says be patient and never does anything. have to force close the app. any ideas there?

Edited by Smiff
Link to comment
Share on other sites

i am using 10.10 but with a .38 kernel.



$ uname -r



anything else relevant?


you're really on it today btw :)



edit: sorry misread you, you CAN reproduce. ok good. thanks.

Edited by Smiff
Link to comment
Share on other sites

For me anyway, it's now looking like an audio related issue.


The program plays a sound (asynchronously) before the 'success' message box pops up and then stops it again after the box has been closed. It's the 'stop' function that's hanging.


Try turning off the success/error sounds in the settings.


Oh and as it has this problem with all modes, just verify a disc (not against an image) to test it quickly... no need to actually burn anything.

Link to comment
Share on other sites

and another correction... it's not the 'stop' that's hanging, it's the initial playing of the sound.


Because it's played asynchronously, the program doesn't have to wait for it to finish (Wine creates a thread and plays the sound in that).


The 'stop' must then be getting caught up in some wait routine (critical section or similar) - meaning the function never returns control to ImgBurn and it's just made to sit and wait.


You can also reproduce the issue by trying to play the success sound twice via the 'Sound' tab in the settings.


It'll appear to work ok the first time, but if you click play a 2nd time the button will stay pressed in and the GUI becomes unresponsive.

Link to comment
Share on other sites

i'm worried about WINE. seems to be very buggy :/

currently imgburn is the only app i use with it, but there will probably be others. Not all of them will be responsive to getting bugs in WINE fixed, or care at all.


anyway thanks, are you going to submit another report to them (please!). at least the first and more important one was taken care of quickly thanks again.

Edited by Smiff
Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.