Jump to content

Problems with brand new DVD Writer...

Recommended Posts

So i bought 3 days ago an ASUS Green DVD Writer (24D5MT) and today i decided to test it on my ASUS Laptop (X555L). Yes i know that it requires a SATA cable but i have one. It is SATA to USB cable and it is been working fine to this day. But my problem is that it wont open the disc tray, and every time i press the button it just blinks green light and stops after 2 seconds of blinking. I've tried everything and it just doesnt work, even the "Eject" button on Windows Explorer but then comes just "It is now safe to unplug device from computer" or something like that. ImgBurn just says "Device Not Ready (Medium Not Present - Tray Closed)"

Here is the log:

I 15:08:19 ImgBurn Version started!
I 15:08:19 Microsoft Windows 8 Core x64 Edition (6.2, Build 9200)
I 15:08:19 Total Physical Memory: 8,289,108 KiB  -  Available: 1,278,104 KiB
I 15:08:19 Initialising SPTI...
I 15:08:19 Searching for SCSI / ATAPI devices...
I 15:08:20 -> Drive 1 - Info: HL-DT-ST DVDRAM GUC0N AS01-37 (E:) (SATA)
I 15:08:20 Found 1 DVD±RW/RAM!
W 15:08:41 Device Arrival Detected!
I 15:08:41 Searching for SCSI / ATAPI devices...
I 15:08:41 -> Drive 1 - Info: HL-DT-ST DVDRAM GUC0N AS01-37 (E:) (SATA)
I 15:08:41 -> Drive 2 - Info: ASUS DRW-24D5MT 1.00 (F:) (USB 2.0)
I 15:08:41 Found 2 DVD±RW/RAMs!

Sidenote: That Drive 1 (HL-DT-ST DVDRAM GUC0N AS01-37) doesnt write, it just reads so thats why i bought this external.

Any help will be appreciated.

Link to comment
Share on other sites

What happens if you press the eject button (The 'E' under the drive selection box - or right click the selection box and pick Eject) in ImgBurn? Any error message?

Normally, if the tray won't open, it's because it's been locked by software. Turning the power off and on would usually reset that.

If after doing that, the button on the device itself still doesn't work, maybe it's just faulty.

What do you have providing power to the device? Hopefully it isn't just being powered by a single usb lead.

Link to comment
Share on other sites

Eject button in ImgBurn didnt do anything, however it says first for 3 second "Device Not Ready (Medium Not Present - Tray Open)" and then says "Device Not Ready (Logical Unit is in process becoming ready)" and then becomes back to "Device Not Ready (Medium Not Present - Tray Closed)" and yes, it is been unfortunately powered by single USB lead but i have USB Hub connected to my computer and the hub requires DC Cable which is always plugged into wall and the disc drive is connected to that USB Hub.

Link to comment
Share on other sites

You're not going to be providing it with enough power from a single usb lead, it's desktop drive.

So the reason it isn't ejecting is probably because it doesn't have enough power to actually do so.

Buy a proper enclosure for the device with a standalone power supply.

Oh and your other drive is a DVD burner, not just a reader.

Link to comment
Share on other sites

Yes, in my experience, power calibration errors are rarely the result of actual power supply issues.  :)  Don't know why they call them that, then.   However, I would make sure the drive is connected to an external enclosure with a proper external power supply to it.  That may also fix your Eject issue.


My experience has been low quality discs are generally the cause of power calibration errors.  Post a log from a failed burn.  Under Help, choose ImgBurn Logs to find the log file, open it, find a failed burn with a power calibration error in it, and post the entire burn and, if applicable, verification log of that operation.  That would tell us more.

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.