Jump to content

My burner seems to be capped at 2x


Recommended Posts

I have a pioneer dvr-110 and my problem is that it seems to be capped at x2 no matter what i do

also the buffer is crazy, goes up and down by huge percentages constantly


I know this is not an imgburn problem(since it happens on nero too) but i dont know where else to ask

i tried other places but they did not know what might be causing this


a bit of info:

I have the latest firmware (1.22)

According to the imgburn & nero logs my DMA is on

I try burning with verbatim x16 and LG x8 and the problem is the same on both

All my burns are successful, just extremely slow at x2 and a crazy buffer( as mentioned above)


system specs:

P4 3.2GHZ

Gigabyte 8I915P Duo

1024MB RAM


I would really appreciate any ideas on what to try

Edited by Shoomy
Link to comment
Share on other sites

as far as the buffer goes how long has it been since you defraged


once upon a time in a land far away w/ a program that was similar to this very one, I was able to tame a wild buffer by defragging, after getting rid of all unnessecary files and moving all video files to media that is what it's there for and keeping as much free space as possible ever after.

as far as the burning is your drive recognizing the media as able to to be burnt faster than 2x?

Edited by l8nights
Link to comment
Share on other sites

Hi again holio


the drive is connected to the primary IDE as the master


i hope this willl help, it is the beginning of a burn in test mode

i dont have a full one cause i guess im too tired to wait 30 minutes for a burn


I 18:50:28 ImgBurn Version started!

I 18:50:28 Microsoft Windows XP Professional (5.1, Build 2600 : Service Pack 2)

I 18:50:28 Initialising SPTI...

I 18:50:28 Searching for SCSI / ATAPI devices...

I 18:50:28 Found 1 CD-RW, 1 DVD-ROM and 1 DVD?RW!

I 18:50:33 Operation Started!

I 18:50:33 Source File: C:\Program Files\iso.iso

I 18:50:33 Source File Sectors: 508,931 (MODE1/2048)

I 18:50:33 Source File Size: 1,042,290,688 bytes

I 18:50:33 Destination Device: [1:0:0] PIONEER DVD-RW DVR-110D 1.22 (J:) (ATA)

I 18:50:33 Destination Media Type: DVD-R (Disc ID: MCC 03RG20) (Speeds: 4x, 6x, 8x, 12x, 16x)

I 18:50:33 Destination Media Sectors: 2,297,888

I 18:50:33 Write Mode: DVD

I 18:50:33 Write Type: DAO

I 18:50:33 Write Speed: 16x

I 18:50:33 Link Size: Auto

I 18:50:33 Test Mode: Yes

I 18:50:33 BURN-Proof: Enabled

I 18:50:36 Filling Buffer...

I 18:50:37 Writing LeadIn...

I 18:50:51 Writing Image...

Edited by Shoomy
Link to comment
Share on other sites



just to recap - you have been into your device manager and removed the controller and re-booted?


have you installed the intel matrix storage manager? http://downloadfinder.intel.com/scripts-df...44&submit=Go%21

and your chipset version is ?

Edited by cornholio7
Link to comment
Share on other sites

Can you take a look at the cables ? The 80 wire ones are obvious as the wires are very fine, the 40's are much more chunky...... Of course you can count them as well - you shouldn't have to count much past 20 to be able to see which cables you have. ;)

Link to comment
Share on other sites

and both buffers go mad?


According to windows device manager, your burner should be in running Ultra DMA 4 I believe. Just check that's the case for you.


Try reading a disc (with a different program of course!), that too should reach a max of 2x if this problem is to make any sense at all!


If you whack the buffer in ImgBurn right up, the 'Buffer' should just go down gradually - until it reaches the bottom where it may then start going mad. Whilst the Buffer is gradually going down, how is the Device Buffer behaving?


The left one basically means the program cant read from your hdd quickly enough. Data goes from the hdd into memory - so should just be using the SATA stuff.


The Device buffer is going from memory to your drive - so will be using your ATA connection. Even though you say the CPU usage isn't high, it seems VERY weird as what you describe has 'DMA problem' written all over it!

Link to comment
Share on other sites

The windows device manager says the burner is running at ultra DMA 5


how can i test my read speed?


and my device buffer(right) is the crazy one while the left one titled 'buffer' is steady at 100%


sorry for being such a novice but i did not understand what it is you wanted me to describe

what is whacking the buffer right up?

Edited by Shoomy
Link to comment
Share on other sites

Ok, if 'Buffer' is always at 100%, reading from your hdd is not a problem.


Have you burnt *any* dvds?


You need to find a program that can read them and report the speed back to you.


Or burn a disc in ImgBurn with Verify enabled and wait for it to verify. The verify part is reading the disc back and it tells you on the screen what speed it's doing it at.


Is anything else attached to the cable your Pioneer drive is on?


Have you tried a different cable?


Oh and when I said whack the buffer right up, I meant go into the settings and change the 'Buffer' slider to 256MB rather than 20MB. But as you've already said the Buffer stays at 100%, there is no need to do that.

Link to comment
Share on other sites

Eh, what did you guys just learn?!


I thought I was explaining the 'whack' term more than anything! lol


Shoomy, like I said, burn and verify something or read a burnt dvd back using another tool.


Ahh, here we go!




Download CD/DVD Speed 4.10 and test the read speed that way.

Link to comment
Share on other sites

and i just tried connecting the burner to my old computer

its a P3 667GHZ with 128RAM


i ran a burn in test mode and the device buffer didnt go under 97%!

and the burn speed was x6 ( althought i set it at x8 - still a huge improvement going over x2)


that was untill the left buffer bar went down, i cause of the crappy computer


Then i reconnected it to my current PC with the same 80 wire cable i used on the P3 and i still have problems




I just tried the read test

never went above x2.3

Edited by Shoomy
Link to comment
Share on other sites

Does test mode on your main pc also go at 2x? (Not sure you've mentioned trying that before).


As you've come from the Digital Digest forums, did you try the filter driver discovery tool I suggested (via someone else perhaps) ?


You get it from the free downloads section over at www.bustrace.com


Either your PC just cant cope with that drive, there's a bad driver in your system, or DMA STILL isn't working properly.


You've got the latest firmware on your pioneer but how about on the motherboard? Is the bios correctly configured to use DMA on the drive etc?


These things are so hard to fix when you're not physically at the machine. I'd have either done it by now or just rebuilt the damn thing lol.

Link to comment
Share on other sites

Yes test mode on my main pc is also x2


my current PC is alot better than the P3 machine so i dont think it cant cope with it


what should i look for in the bios? i do not know what to configure there




by filter driver discovery tool im hoping you meant the Filter Driver Load Order v1.0.005


i ran it and it shows 4 things

upper device filter: redbook

device object: PIONEER DVD-RW DVR-110D

lower class filter: pxhelp20

lower device filter: imapi

Edited by Shoomy
Link to comment
Share on other sites

Sorry, by 'cope' I meant that is has some compatibilty issue with it, rather than it not being powerful enough. That's why I said to check the motherboard bios.


I guess you didn't build the PC yourself or you'd already know how to configure the bios, so just go to the site of whoever made your machine and find the latest bios update for it. Once you're sure it's on the latest version, select the option to reset to default values.

Then just double check everything and anything that's related to IDE, DMA etc is enabled and on the fastest option. Most bios auto detect the drives now. I have a 875 chipset on my board but I can see the diagnostics screen just before windows boots up and it clearly says what speeds my drives are running at.


To see that diagnostics screen you may need to disable 'quiet boot' / 'quick boot' within the bios and also possibly turn off the 'show logo' option.


As for the filter tool, yeah that's the one.

Only thing I don't like seeing there is the pxhelp20 driver. That's normally from recordnow max or some other 'pinnacle' tool.

If you're not using such tools, I suggest you uninstall them.


There's a chance pxhelp20 wont vanish. You 'could' remove it via regedit but perhaps you're not quite ready for that task. Maybe in device manager with 'show hidden devices' enabled in the menu system, you could find it in the 'Non-Plug and play drivers' section. Just right click it and select uninstall.


What you could also do for me is to export the following key via the regedit tool.




Just navigate to it, right click and then select export.


Save it to a file, open that file in notepad and then copy + paste the contents to a post here in the forum.

Link to comment
Share on other sites

I did build my pc myself but i guess i didnt change much in the bios except boot from hardisk and disabled onboard raid(just wondering if this might be causing the problem)

but i did go to the gigabyte site and found that the latest bios for my mobo is F6 which is what i have and i will configure things as you said


I did not find pxhelp20 on non-plug and play drivers


The reg file:




@="IDE ATA/ATAPI controllers"














"DriverDesc"="Primary IDE Channel"





















"DriverDesc"="Intel® 82801FB Ultra ATA Storage Controllers - 2651"











"DriverDesc"="Secondary IDE Channel"























Link to comment
Share on other sites

Oh my god.


I played with bios PATA SATA settings

did a test with imgburn

and it burned at x8 it was a bit unstable for a sec left buffer dropped alot but it got back up!



I have no idea what i did

i will try a burn now and see what happens

if this works i will find out what i did and tell you about it


and i cant thank lightning and cornholio enough for helping so much



Just burned 4482MB at x16 in 6 minutes!


And i found out what i did

I set the on chip sata mode to Combined and the PATA IDE Set to ch.1 master/slave


i dont know why i did it or what it means

but i do know it fixed my problem


i hope this helps someone with the same problem

Edited by Shoomy
Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.