Jump to content

CD audio burning broken on Wine


Recommended Posts

It seems that the CD audio burning will not work on Ubuntu Linux and Wine. This is probably not a problem with ImgBurn as the same files burned fine on my Windows partition with the same files.


Here are some screen shots of the errors








I will be doing more testing and post some logs as I go. I will also be trying an earlier version of Wine.


Has anyone else running Linux been able to get this to work?

Edited by wild77
Link to comment
Share on other sites

I knew DirectShow failed and the ACM fallback was actually tweaked especiallly for Linux/Wine burning so it would at least handle MP3 without erroring out!


I could have sworn I actually created a disc under ubuntu but perhaps I was more concerned about it just loading / accepting the files.


It really shouldn't be failing on the 'acmstreamconvert' function if all the other functions used to detect if the conversion is possible have worked. Naughty Wine!


ACM isn't good at doing conversions from different sample rates, number of channels etc (it errors out) so it's far less flexible than DirectShow - but of course there doesn't appear to be any support for DirectShow decoding (at least not using the 'SampleGrabber' filter) within Wine.


EDIT: I've since found + fixed an issue with the ACM fallback code. v2.4.1.0 should be ok ;)

Link to comment
Share on other sites

I know that making ImgBurn work on Linux is probably not on the top of your list, and yes Wine is very buggy at best!


Maybe having a couple of your Beta Testers running Linux would help.

(At least) one of the betas has a linux build.



Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

I have imgburn running in Wine with 7.04 and no problems burning although I just downloaded it and installed it yesterday. (I had tried it over a year ago in Wine but did not install correctly)


Today it took a while to get it to detect my device, but it does now. One of the features I do like is the ability to change booktype. This was error ed out on me several times, until I changed the setting to ASPI instead of the Microsoft SPTI setting. This worked to allow me to change the booktype where before I go an error no sense information detected.


Just thought I would post this in case anyone was having troubles with the booktype feature in Ubuntu.

Link to comment
Share on other sites

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.